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Making Printed Circuit Boards with Orcad Layout
(Getting your Capture Schematic ready for Layout)
 For the purposes of demonstration, we will design a simple board in Orcad Capture and import it into Layout.


Make a schematic of a board in Orcad Capture.

Open Orcad Capture.

Select File -> New -> Design.

A blank page appears with a boarder and title block.




Fill out Title Block information.




See www.princeton.edu/~mae412/SCHEMATICS/titleblock.pdf for an explanation of the Title Block.

See www.princeton.edu/~mae224/labmanual/orcad_p1.doc basic Orcad Capture instruction.
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Since you are building a real board, there are things to be aware of:


The Op Amp on the left is for a DIP chip while the right one is a metal can package (notice
 the different pin numbers).




Orcad names a new chip for each part.  Use unused sections of the chip to lower total
 number of components.




Use ports to bring signals to and off the board.





Here's the test schematic.
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Now minimize the schematic page and select the *.opj or project window.




From the menu bar, go to Tools -> Create Netlist
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Select the Layout tab

Check off  "Run ECO to Layout".

Make a note of where the *.MNL file is being created.




Notice that there is now a file listed under Outputs.

Exit out of Capture and open Layout.

Go to "Making Printed Circuit Boards with Orcad Layout Part 2"
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Making Printed Circuit Boards with Orcad Layout Part 2
(Setting up Layout for your Capture Schematic)


From file menu select "New".  The "Load Template File" dialog box will appears. 




Go with DEFAULT.TCH, unless you are doing something special like an ISA or PCI board.




Select the *.MNL file you made a note of in Capture.
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Save the layout file.  This is the file you will open to make changes to Layout later.

The Automatic ECO Utility will prompt you to select a footprint to the component.  Click on "Link existing footprint to
 component ...".  You can either browse the library or see the Footprint Library book in J207 to make things easier.  If
 you want to modify a footprint, do it later in Layout versus using the "Create or modify footprint library ...". 
 Modification takes time and is easier within the program.




Here's the selection for the LM747.  I selected the DIP100T library to give us footprints for Dual In-line Packages whose
 leads are 0.1" apart, and are Through hole components (versus DIP100B which are surface mount).




Under footprints, select DIP.100/14/W.300/L.700 which is a DIP Chip with pin that are 0.1" apart, 14 pins, and a
 component silkscreen (the green box) that is 0.3" X  0.7".  Don't worry too much about the silk screen.  We buy
 economy prototyping boards that do not have the silk screen.  If we were building full production boards, it would
 appear as the white writing on the board.
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Now your design should look like this.  A drill chart and a bunch of footprints connected together by the ratsnest.

The ratsnest shows the interconnectivity between the components.  It helps with placing the components.

In the menu bar go to Options -> System settings ...

Click on "Workspace Settings...".  Note:  This box is also used to adjust the grids for custom parts or placement.




I'm going to chose a "Very Small" workspace.  !7" X 17" is still larger that I will ever need.  Then click on
 Convert.. and then OK.




Go to "Making Printed Circuit Boards with Orcad Layout Part 3"
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Making Printed Circuit Boards with Orcad Layout
 Part 3

(Laying out the board)

Now you will create the board outline.  The things you need to consider are the
 following:


The size board you need.  Maybe you are mounting this into something that

already exist.

Boards are priced by square inch, so don't waste space.

Yet, don't make boards too small.  It's harder for the autorouting program, and
 companies will charge a high density drilling fee if you have too many holes per
 square inch (an average of 24 holes per square inch).

Don't forget the large physical things like heat sinks, terminal blocks and mounting
 hardware.


Select the Obstacle button from the tool bar .


Select the Global Layer from the layer pull down list
 .

I usually place the board above the drill chart.  Click on the workspace for the lower
 left corner, then move up click, move right click, move down click then press ESC.  A
 yellow box should trace out.  Use the X Y coordinates in the upper left to determine
 your outline size as you trace.  Remember, I'm using mils or 1000th of an inch.  My
 example is 2" x 3".

http://www.princeton.edu/index.shtml
http://www.princeton.edu/~mae/MAE.html
http://www.princeton.edu/~mae433/index.html
http://www.princeton.edu/~mae433/text.html
http://www.princeton.edu/~mae433/grading.html
http://www.princeton.edu/~mae433/staff.html
http://www.princeton.edu/~mae433/demos.html
http://www.princeton.edu/~mae433/lectures.html
http://www.princeton.edu/~mae433/labs.html
http://www.princeton.edu/~mae433/electronics.html
http://www.princeton.edu/~mae433/electronics.html
http://www.princeton.edu/~mae433/programs.html


Layout Part 3

http://www.princeton.edu/~mae433/LAYOUT_TUTOR/layout_part_3.html[7/8/2015 22:25:06 PM]


  


Click on DRC  so that it's gray.  The Design Rule Checker feature gets in the way at
 the beginning of the process.  The dotted line should disappear.


The datum  is the reference place for the coordinate system.  The datum
 represents 0,0.  I prefer that the lower left corner of the board be 0,0.  Go to Tool ->
 Dimension -> Move Datum.  Click on the lower left corner to move the datum.


Select the component button from the tool bar  and "TOP" for the layer

.

Start moving components to  within the yellow outline.





The board we are building only has a top and bottom (no inner layers), so go to Tool ->
 Layer -> Select from a spreadsheet ...
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Select a Layer and from a right click choose "Properties" to edit the layer. 
Change the
 GND, POWER and any INNER layer to say Unused.




Let's take a second to look at the nets.


Go to Tool -> Net -> Select From Spreadsheet...

Press "Cancel" for the "Net Selection Criteria".
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By default Capture name it's nets Nxxxxx.  Because of the ports we added in capture
 with good labels, we have good net names.  This will allow you to pick pins for things like
 headers with little confusion.  The Nxxxxx names we have are probably nets that only go
 from component to component and not off the board.

So from the Net names you can figure out how big of a header is needed.  I count 14
 from the list, but usually I like one ground for each signal in and out so I think I need 25,
 (11 x 2 = 22 for signal and grounds, and 3 for power).

Go to "Making Printed Circuit Boards with Orcad Layout Part 4"
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Making Printed Circuit Boards with Orcad Layout
 Part 4

(Modifying Parts)
 The headers in Layout are 0.1", but the ones we have are 0.2".  For my design I will need two
 headers of 12 contacts.


Double check that the component button from the tool bar
  and "TOP" for the layer


 is selected, then right click on the workspace and select
 "New...".



 I'll choose  J1 for my "Reference Designator" and then click on "Footprint..."
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 The footprint that comes the closest is the positive lock connector library (PCON100T). 
 We will use the POLCON.100/VH/TM1SQS/W.300/ footprints so that the pins are in the
 middle of the block and since I need a 12 pin header I will select a 23 pin footprint.  I
 have chosen 23 because my pins are 0.2" apart instead of 0.1" and then take off 1 so
 the last pin is near the silk screen ([12 x  2] - 1 = 23).

 To modify the part, click on the Library Manager button on the tool bar .

 Find the footprint POLCON.100/VH/TM1SQS/W.300/23 in the PCON100T in library and
 then press "Save as...".  I put mine in a new library and named it "Header 12" so I can find
 it for future projects.

Now I can make changes without changing the main library.

First get rid of the unwanted pins by using the pin tool from the tool bar
 .


  to
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 Then move the pins so that there are 0.2" apart.  If the grid wont allow you to place the
 pins in the right places then click on "Options" then "System Settings..." and change the
 Place grid to 10.  Then press "OK".



 The part should look like this.



 I will also delete the 23 or change it to a 12.
 Save the new footprint and close the library manager.

 Now replace the old footprint with the new one.
 Double click on on of the header components and then press "Footprint".
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Select the footprint you just saved.



 Select "Replace footprint for all components" so that J2 changes as well.
 It's okay if it says that the new component has fewer pins.  You just went from 23 to 12.



 It looks like I need an extra 0.1" to 0.2" to fit everything.

 Select the Obstacle button from the tool bar .

 Select the Global Layer from the layer pull down list .
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 Stretch out the yellow board outline to get the new shape.

Go to "Making Printed Circuit Boards with Orcad Layout Part 5"
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Making Printed Circuit Boards with Orcad Layout
 Part 5

(Mounting holes, adding to nets and traces)
 The mounting holes are treated just like components. 
 Add them just like you did the header, except use the Layout library and the footprint is
 MHOLE 1.




Now we need to add the header pins to the nets.

Select the Pin button
 .

Double click on pins you want to add to a net.



 This shows us the name of the Pin "J2.1" and its net "-" or none in this case.
 Use the pull-down list to select the net you want, but this will only work for nets that have two
 or more pins in them already.
 To add pins to nets that have less than two pins, you must first get the name of two pins you
 want to add.
 I want to add "J1.3" and "R5.1" to the "Sum In 3" net.
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From menu go to Tool -> Net -> Select From Spreadsheet...

Select net from spreadsheet and right click.

Pick "Connections edit" from pop up menu.



 Type in pin numbers.
 Make sure that "Add" is selected and press OK.

 Connect all pins.
 To check which pins belong to which net, right click on a net from the spread sheet (Tool ->
 Net -> Select From Spreadsheet...) and go to "Properties"




 Check off "Highlight" and then press "OK"

 Pins that belong to the net and their ratsnest are now white.
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 Now it's time to lay down some traces.


Go to Auto -> Autoroute -> Board, and the board will route the traces.




 Check that all the traces are red and blue.

 If other colors are present, you didn't turn off on of the layers.  Click here to go back to
 that section.

 This board could now be sent out, but the traces are pretty thin.

 To make the traces wider,  go to the "Edit net" dialog box (Click here to see how to do
 it).
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 I use 25 for signals and 50 power and output.

 Grounds I like thick, but since it can go all over the board, I will set "Min Width" to 25 as
 well as "Conn Width" and "Max Width" to 50.

 Now unroute the board by going to Auto -> Unroute -> Board, and the board will route
 the traces.

 Now reroute it with the new numbers.




 Now we are ready for the Post Processes.

Go to "Making Printed Circuit Boards with Orcad Layout Part 6"
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Making Printed Circuit Boards with Orcad Layout Part
 6

(Hole sizes)
 The company I use gives me 8 drill sizes that are free, and charges about $9.00 for an extra drill size,
 so adjusting some of the holes will could save lots of money.

Drill
 Number

 Set

Drill
 Size Use

#70 0.028" via holes and fine lead parts
#65 0.035" IC's, 1/4 watt resistors
#58 0.042" TO-220, 1/2 watt resistors
#55 0.052" Large connectors
#53 0.060"  
#44 0.086" TO-220 Mounting holes
1/8" 0.125" 4-40 screws
#24 0.152" 6-32 screws

 

From the Drill Chart below there are 48 holes sizes 0.031" and  0.034".  I will shift them up to a size
 0.035".
The 0.110" holes will become .125" and the 0.028" & 0.042" I'll leave alone.

One method of doing this is to modify the the footprints and replace the pads with different pads
 from the pad library.
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This is good if you want to create new footprints for parts that you want to use again in the
 future.
One problem is that this is very time consuming.

The second way is to modify the padstack local library from the spreadsheet.
Go to Tool -> Padstacks -> Select From Spreadsheet...
Cancel the "Select Padstack" dialog box.
The spreadsheet shows all 84 holes with all it's layers (even those that are unused).
Scroll down the spreadsheet and locate the number 31or 34 (stands for 0.031",0.034") under the
 "Pad Width" & "Pad Height" column and the "DRLDWG" AND "DRILL" layers.

In the pad above, double click on each of the "31"s and change them to "35"s
Lastly make sure the TOP" and "BOTTOM" layers within the padstack are larger than 35.
This one is 52, so we are okay.  This will the plating that is seen on the top and bottom of the
 board, around the hole.

Now let the Drill Chart update by going to Tool -> Drill Chart -> Properties, then press "OK".
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If you got all the padstacks, then the unwanted sizes should vanish.
From the Drill Chart, the "SYM" or symbol column needs to have a unique symbol.

Go to Tool -> Drill Chart -> Select From Spread Sheet...

Double click the number you want to change, and replace it with an unique number 1 - 20.
There are 10 styles of symbols in two different sizes.  1-10 (Large) 11 - 20 (Small).  Large holes
 (0.125") I'll make a large symbol.
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To see the symbols in action hide all layers except "Global Layer", "SST" & "DRD".  Hide the layer
 by selecting it from the pull down menu in the tool bar, and press "-" key.  Select the "DRD" layer
 last so the symbols are on top.

Go to "Making Printed Circuit Boards with Orcad Layout Part 7"
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Making Printed Circuit Boards with Orcad Layout
 Part 7

(Post Production)
 The *.MAX file that we are using to make the board are an over all view of the board.  The
 company that will produce the boards needs the board broken down into something that
 can be coded into a machine.  So now we will  generate the files that need to be
 transferred. 
 Go to Auto -> Back Annotate.  This will bring changes made in Layout back into Capture.
 Go to Auto -> Run Post Processor.




"OK"  the next two boxes.  They just tell me which file are the "Gerber" (*.GTD) and "Drill tape"
 (Thruhole.TAP) files, also a "Post Processor Report" (*.LIS).  Just close it out.

Above is a list of all the files just generated, along with my original *.DSN, *.MNL and *.MAX
 files.

The company I use will build me a two sided board with no silkscreens. So out of that big list
 above, here is want they need.


TOP = Gerber For Top Layer

BOT = Gerber for Bottom Layer
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TAP = Drill Cordinates & Tool Sizes

DTS file contains tool sizes and should be included if your TAP file does not have the tool
 sizes in it (send it to be safe).

DRD is the drill drawing and is not needed, but can help them.

LIS file contains aperture info that should be sent incase the RS274x (embedded

aperture) option was not selected.


The company I use provide software to aid with the transfer of the files.  Check the company
 you will use for details.

Things  not covered in this document can be found in the Layout tutor under help.  This points
 were not need to make this board, but are good to know.


Adding dimensions

Cleaning up the board

Adding obstacles

Manually laying or moving traces.
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