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1. Introduction
This tutorial is intended for users who need to become quickly familiar with RapidWorks.
Before getting into the detailed instructions for using RapidWorks, this step-by-step tutorial aims at giving you a
feel for what you can accomplish with the product.
This tutorial will guide you completely design a watertight mesh model using powerful mesh modeling Tools. You
will learn about the mesh modeling methods that can create a watertight mesh model from a set of 3D scan data

A Set of Scan Data

Optimized Mesh Model

Training time required : approx. 30 min.
Level of Difficulty : Basic

2. Data Files
Mesh_Optimization.rwl – a set of scanned mesh data of a helmet model.

Download: http://nextwiki.s3.amazonaws.com/resources/application/octetstream/659cb9c0a2da012f2eb600254b9c869c-g1qdiiny87pzi.rwl
The sample data for this tutorial is provided by INUS Technology. They are the property of INUS Technology and
are used for informational purposes only. Other than to identify this software and publication, individuals or
organizations purchasing the software are not entitled to use the sample data without INUS Technology’s prior
written consent.
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3. Overview
What will you learn in this course?
•

Remove noises from a set of scan data

•

Align meshes

•

Merge meshes into a single mesh

•

Heal defects from a mesh

•

Enhance quality of a mesh

•

Optimize a mesh

What will you learn to do in this course?
•

You can easily and quickly create a single mesh from a set of scanned meshes by using Mesh Buildup Wizard.

•

You check defects in the mesh and heal the defects from the mesh by using Healing Wizard.

•

If the mesh has some missing holes, you can easily fill the holes by using Fill Holes and Rewrap commands.

•

You can finally enhance quality of the mesh and optimize it.

What does this exercise cover?
Step 1. Import Scan Data and Run Mesh Buildup
Wizard
You can import a set of scanned meshes as target scan
data into the application and run Mesh Buildup Wizard
to create a single mesh from them.

.

Step 2. Create Single Mesh from A Set of Scanned
Meshes
You can easily and quickly create a single mesh from a
set of scanned meshes by using Mesh Buildup Wizard.
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Step 3. Heal Defects
You can check defects in the mesh and heal the defects
from the mesh by using Healing Wizard.

Step 4. Fill Holes
You can easily fill some missing holes in the mesh by
using Fill Holes and Rewrap commands.

Step 5. Enhance Quality of Mesh and Thicken Mesh
You can enhance the quality of the mesh and thicken
the mesh.

Step 6. Optimize Mesh and Check Result
You can finally optimize the mesh and check the
modeling result.
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4. Modeling Process
Step1. Import Scan Data and Run Mesh Buildup Wizard
STEP1

STEP2

STEP3

STEP4

STEP5

STEP6

In this step, you will learn how to import a set of scanned meshes as target scan data into the application and
run Mesh Buildup Wizard to create a single mesh from them.

Imported A Set of Meshes
1. Import Scan Data and Run Mesh Buildup Wizard
Follow this step by using the Mesh_Optimization_01~19.stl files.
① Click the File Import in the Toolbar or choose Insert > Import in the menu.
② Select the scanned mesh files (Mesh_Optimization.rwl) and click the Run Mesh Buildup Wizard button.

Download:http://nextwiki.s3.amazonaws.com/resources/application/octetstream/659cb9c0a2da012f2eb600254b9c869c-g1qdiiny87pzi.rwl

Tip. You can easily select a set of scanned meshes with ‘Shift’ key
③ Check that a set of scanned meshes are imported into the application in the Model View.
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Note. This is a set of scanned meshes for a helmet model. As soon as the scanned meshes are
imported into the application, Mesh Buildup Wizard automatically opens and you can create a single
mesh from a set of scanned meshes by following mesh buildup stages in the Mesh Buildup Wizard.

Step2. Create A Single Mesh from A Set of Scanned Meshes
STEP1

STEP2

STEP3

STEP4

STEP5

STEP6

You have imported a set of scanned meshes into the application and run Mesh Buildup Wizard to create a
single mesh from them so far.
In this step, you will learn how you can easily and quickly create a single mesh from a set of scanned meshes
by using Mesh Buildup Wizard.

Imported A Set of Meshes
1. Data Preparation

Generated Single Mesh

Mesh Buildup Wizard consists of five different stages such as Data Preparation, Data Editing, Data Pre-Aligning,
Best-Fit Aligning, and Data Merging.
In the first stage, you can choose a scanner type which you have used to scan a target object.
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① Check that all imported meshes are registered as the target scan data in the Select option.

Note. You can also check the imported meshes in the Entity Thumbnails View.
If you move your mouse cursor over the one of entities in the Entity Thumbnails View, a small widow pops
up and you can check each one of imported meshes in the window, as shown in the image below.

Rotate, Pan and Zoom-In/Out are available in the window.
② Check the Small/Medium Size Object Scanner option in the Set Scanner Type.
Note
Mesh Buildup Wizard provides different parameters and options during the process according to your
definition of scanner type.
This tutorial will use the Small/Medium Size Object Scanner type for the helmet model.
③ Turn the other options off in the Set Data Condition, as shown in the image below.
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④ Click the Next Stage button to continue.

2. Data Editing
Mesh Buildup Wizard consists of five different stages such as Data Preparation, Data Editing, Data Pre-Aligning,
Best-Fit Aligning, and Data Merging.
In the second stage, you can edit the meshes. If the meshes have some noises or you have picked up some floor
poly-faces while scanning, then you can remove those unwanted areas in this stage.

Note. Mesh Buildup Wizard provides several editing tools in the second stage.
You can manually select some unwanted areas in the meshes and delete the areas as well as you can
easily find noisy clusters from the meshes and remove the noises.
If you think that the meshes have no noises, you can skip this stage.
Even if you skip this stage, note that you can edit the meshes whenever you need to edit them because
these editing tools will be available in different stage as well.
① Click the Find Floor button to find floor poly-faces in the meshes.
② Select a point on the planar area of the mesh as a seed point to find planar floor poly-faces, as shown in the
image below.

Note. Just pick a point on the mesh and then Mesh Buildup Wizard automatically finds the planar floor
poly-faces in the mesh by using the seed point even though the mesh has complex freeform feature
shapes.
The Find Floor button can be toggled on / off. So, you can continuously find floor poly-faces from the
other meshes.
③ Continue selecting points on the planar area of the other meshes, as shown in the image below.

④
⑤
⑥
⑦

Click the Delete Selected Entities (Delete) button.
Check the result in the Model View or in the Entity Thumbnails and toggle off the Find Floor button.
Set the Max. Poly-Vertices/Faces Count Per Noisy Cluster to 100.
Click the Find Noisy Cluster button to find noisy clusters from the meshes.
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Note
Mesh Buildup Wizard automatically detects small clusters which are nothing but groups of poly-faces
whose poly-faces count is smaller than the defined Max. Poly-Vertices/Faces Count Per Noisy Cluster.
After the small clusters are selected, you can remove them by clicking the Delete Selected Entities
(Delete) button or ‘Delete’ key.
⑧ Check the selected small noisy clusters in the Select list, as shown in the image below.

⑨ Click the Delete Selected Entities (Delete) button.
⑩ Check the result and then click the Next Stage button to continue.

3. Data Pre-Aligning
Mesh Buildup Wizard consists of five different stages such as Data Preparation, Data Editing, Data Pre-Aligning,
Best-Fit Aligning, and Data Merging.
In the third stage, you can approximately align meshes.

Note. Mesh Buildup Wizard provides two different alignment methods such as Local Based On Auto
Guess and Local Based On Picked Point in the third stage.
The Local Based On Auto Guess method is the one of methods in the third stage which allows you to
easily align the meshes no matter where the meshes are. The meshes are automatically aligned with
each other by using the geometric shape information.
The Local Based On Picked Point method is the other method which allows you to manually align the
meshes by picking several corresponding points on the meshes.
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① Check the Local Based On Auto Guess in the Method.
② Check that all the meshes are registered as the target meshes in the Moving.
③ Set the Preference to the middle in the Slide bar and adjust the options, as shown in the image below.

Tip. If you set the Preference to the Speed, the alignment will be quickly done. But the alignment result
may be incorrect if the shapes of meshes are simple. That means if there are no geometric feature
shapes on the meshes which can constraint each other then it becomes difficult to align them with this
option setting.
If you set the Preference to high Quality, Mesh Buildup Wizard will try to align the meshes as close as
possible by using the geometric shape information. But, the alignment process may take a long time.
④ Click the Apply button and check the result.

Meshes in which the normal direction has been reversed

Note
All the meshes are automatically aligned, but some meshes are still not aligned as you can check in the
result.
If normal direction of meshes has been reversed or some noises are still there in the meshes, then the
automatic alignment may not be completely done.
In this case, you can manually edit these meshes by using the Edit Tools as you did in the previous
stage and then you can manually align the modified meshes with the aligned meshes by using the Local
Based On Picked Point method.
⑤ Pull down the Edit Tools by clicking the option.
⑥ Click the Reverse Normal Of Entire Mesh/Point Cloud button to reverse the normal direction of meshes.
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⑦ Select the meshes (Mesh_Optimization_01) whose normal direction has been reversed, as shown in the image
below.

Tip. If you find it difficult to locate the meshes whose normal direction has been reversed, then you can
change the display color for their back face.
You can change the display color for the back side of meshes in the Back Face option under the General
section in the Display tab.

If you change the display color in the Back
Face option to ‘User Defined’, the color of back
side of meshes will be changed to the color you
define/pick.
You can also define the color under the display
tab in Preferences (File > Preferences).

⑧ Check the result, as shown in the image below.
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Fixed Normal Direction of Mesh

Note. Check if floor poly-faces are still remained. If so, delete the poly-face as follows:
i. Select the Delete Floor button
and then select a point on the mesh as a seed point to find
planar floor poly-faces, as shown in the image below.

ii. Click the Delete Selected Entities (Delete) button.

⑨ Return back to the alignment process by clicking the Method option.
⑩ Check the Local Based On Picked Point option.
⑪ Select the aligned meshes to register them to the Reference and click the Moving button to register the other
meshes to the Moving.
⑫ Select the other meshes as the target Moving meshes, as shown in the image below.
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Reference Meshes

Moving Meshes

⑬ Pick corresponding points on the Reference meshes and the Moving meshes in the each Model View in
consecutive

consecutive

order

order, as shown in the image below.

Note. At least three corresponding points are needed to accurately align the Moving meshes to the
Reference meshes.
Tip. If you want to cancel the last picked corresponding point, then you undo the operation by using ‘Edit
> Undo’ or clicking ‘Ctrl + Z’ key
⑭ Click the Apply button.
Note. After the operation is completely done, the aligned moving meshes are automatically registered as
the Reference.
If you need to align the other meshes to the Reference meshes, you can continue to apply the alignment
to the meshes, same as the previous step.
⑮ Check the result and click the Next Stage button to continue.
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4. Best-Fit Aligning
Mesh Buildup Wizard consists of five different stages such as Data Preparation, Data Editing, Data Pre-Aligning,
Best-Fit Aligning, and Data Merging.
In the fourth stage, you can accurately align meshes.
Note. All the meshes have been approximately aligned each other.
Now, you can accurately align the meshes.
① Click the Moving button to register the meshes as the target Moving meshes and select all the meshes.
② Turn all options off in the Options, as shown in the image below.

③ Click the Apply button.
Note. All the meshes will be accurately aligned.
④ Check the deviation between the aligned meshes by selecting the Max./Min./Avg. Deviation button in the
Accuracy Analyzer(TM).
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Tip. You can check how the meshes are accurately aligned to each other by using the Accuracy
Analyzer(TM). And if you move your mouse cursor over one of meshes in the Entity Thumbnails, you can
also check a deviation between the specific mesh and the others.

⑤ Click the Next Stage button.
5. Data Merging
Mesh Buildup Wizard consists of five different stages such as Data Preparation, Data Editing, Data Pre-Aligning,
Best-Fit Aligning, and Data Merging.
Finally, you can merge the aligned meshes into a single mesh.
Note. All the meshes have been accurately aligned to each other.
Now, you can merge all the meshes into a single mesh.
This is the final stage of Mesh Buildup Wizard.
① Adjust the Geometry Capture Accuracy option, as shown in the image below.
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② Click the Apply button.
③ Check the result.

Note. All the meshes are completely merged into a single mesh.
④ Click the OK button to close the Mesh Buildup Wizard.
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Step3. Heal Defects
STEP1

STEP2

STEP3

STEP4

STEP5

STEP6

You have created a single mesh from a set of scanned meshes by using Mesh Buildup Wizard so far.
In this step, you will learn how to check defects in the mesh and heal the defects on the mesh by using
Healing Wizard.

Generated Single Mesh

Detected Defects

1. Heal Defects
Now, you can optimize the mesh. In the first step of optimization process, you can check defects on the mesh and
you can fix it.
Note. When the meshes which have been scanned in different directions by using 3D scanner are
aligned and merged with each other, some defects such folded poly-faces, dangling poly-faces, small
noisy clusters, etc. may occur in the merged mesh. To optimize the mesh, first you need to heal the
defects on the mesh.
① Select the generated mesh in the Feature Tree or in the Model Tree and click the Mesh button in the Tool Palette
to optimize the mesh in the Mesh mode.
Tip. You can also enter the Mesh mode to optimize the mesh by double clicking the generated mesh in
the Feature Tree or in the Model Tree.
② Click the Healing Wizard in the Toolbar or choose Tools > Mesh Tools > Healing Wizard in the menu.
③ Check the defects on the mesh.
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Note. Healing Wizard automatically detects defects in the mesh and also displays them with highlighted
colors on the mesh.
Tip. Folded Poly-Faces
This option will be automatically checked when some poly-faces have been folded together on the
same place. It will remove these poly-faces.
o Dangling Poly-Faces
This option will be automatically checked when 2 or 3 open side poly-faces are hanging on the
boundary of mesh, as shown in the image below.

< 2 side opened poly-face >
It will remove these poly-faces.

<3 side opened poly-face >

o Small Clusters
This option will be automatically checked when small clusters (a group of connected poly-faces) which
have less poly-faces than the specified number of poly-faces are detected in the mesh, as shown in
the image below.

< Small Clusters >
It will remove these poly-faces.
o Small Poly-Faces
This option will be automatically checked when small poly-faces whose area is smaller than the
specified area are detected in the mesh, as shown in the image below.

< Small Poly-faces >
It will remove these poly-faces.
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o Non-Manifold Poly-Faces
This option will be automatically checked when some non-manifold poly-faces or redundant poly-faces
are detected in the mesh. It will remove these poly-faces.
o Crossing Poly-Faces
This option will be automatically checked when some crossing poly-faces are detected in the mesh.
Healing Wizard provides three different healing methods such as Smooth, Merge Poly-Vertices, and
Delete And Fill Hole in the option.
- The Smooth which is one of the methods smoothly regenerates poly-faces around the crossing
poly-faces.
- The Merge Poly-Vertices which is another method merges poly-vertices around the crossing polyfaces.
- The Delete And Fill Hole which is the other method removes poly-faces around the crossing polyfaces and fills the resulting holes.
o Small Tunnels
This option will be automatically checked when some poly-faces whose shape is like a tunnel or
handle are detected in the mesh. It will remove these poly-faces.
④ Click the OK button.
⑤ Check the result.

Note. All the detected defects are removed from the mesh.
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Step4. Fill Holes
STEP1

STEP2

STEP3

STEP4

STEP5

STEP6

You have checked defects in the mesh and healed the defects from the mesh by using Healing Wizard so far.
In this step, you will learn how you can easily fill some missing holes in the mesh by using Fill Holes and
Rewrap command.

Closed Mesh

Opened Mesh
1. Fill Holes

In the second step of optimization process, you can fill holes and create a closed volume mesh.
① Click Fill Holes in the Toolbar or choose Tools > Mesh Tools > Fill Holes in the menu.
Note. You need to fill the holes to create a high quality volume mesh.

Tip. If you feel that it’s difficult to find missing holes in mesh, you can easily find the holes by changing
the displayed color for the boundaries of mesh.
You can change the displayed color for the boundaries of mesh in the Boundary option under the
Mesh/Point Cloud section in the Display tab.
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If you change the display color in the Boundary
option to ‘User Defined’, the color of boundaries
of mesh will be changed to the color you
define/pick.
You can also define the color under the display
tab in Preferences (File > Preferences).

② Check the Method is Curvature and click the Add Bridge button to create a bridge between the poly-edges in
the hole.
Note. If a hole is big or complex to fill, the bridge helps you to divide the big hole into several small holes
and easily fill the holes.
③ Select the poly-edge in the left side of the boundary and drag the bridge to the other poly-edge in the right side of
the boundary, as shown in the image below.

④ Add a bridge between the other poly-edges, same as the previous step.
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⑤ Click the Boundaries button and then select the divided boundaries, as shown in the image below.

]
⑥ Check the Smooth Boundary option in More Options
⑦ Click the Preview button and check the previewed result.

⑧ Click the Accept button.

2. Wrap Entire Mesh
When the mesh has too many holes and the holes are complex and difficult to manually fill, you can easily fill the
holes at one shot by using Rewrap function.
① Check the Rewrap in the Toolbar or choose Tools > Mesh Tools > Rewrap in the menu.
Note. Rewrap allows you to wrap the entire mesh. You can easily create a closed volume mesh even
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though the mesh has complex holes and missing feature areas.
② Adjust options, as shown in the image below.

Tip. You can check the current average poly-edge length.
If you set the Edge Length Multiplier to ‘1’, the mesh will be rewrapped with current average poly-edge
length.
If you set the Edge Length Multiplier to ‘2’, the mesh will be rewrapped with average poly-edge length
which is two times bigger than current average poly-edge length.
③ Click the Preview button.

Note. You can see that all the holes are completely filled in the preview result.
④ Check the previewed result and then click the Accept button.
Tip. You can completely fill the holes in the mesh by using Rewrap command, but if the mesh has some
obviously big missing feature areas, then apply the Rewrap command to the mesh after adding any
bridges in the Fill Holes command. You will then get a better result.
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Step5: Enhance Quality of Mesh and Thicken Mesh
STEP1

STEP2

STEP3

STEP5

STEP4

STEP6

You have filled holes in the mesh by using Fill Holes and Rewrap command so far.
In this step, you will learn how you can enhance the quality of the mesh and thicken the mesh.

Closed Mesh

Thickened Mesh

1. Enhance Quality of Mesh
You can enhance the quality of the mesh.
① Click the Enhance Shape in the Toolbar or choose Tools > Mesh Tools > Enhance Shape in the menu.
Note. Enhance Shape command allows you to enhance typical feature shapes in the mesh.
The low curvature areas will become much smoother and high curvature areas will become much
sharper in the mesh.
② Set the Sharpness to the middle and the Overall Smoothness to Max, as shown in the image below.

Note. You can adjust the weight of the sharpness and the overall smoothness by controlling the slide bar
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and you can also set the iteration of those enhancements by controlling the Enhance Level.
③ Click the Next Stage button to continue.
Note. You can adjust the iteration of the enhancements in the second stage of the Enhance Shape
command while you preview the result.
④ Check the previewed result and then click the OK button.

2. Thicken Mesh
You can also thicken the mesh.

Note. Currently, the mesh is constructed by poly-faces as a shell.
You can create a volume mesh which has constant thickness by using Thicken command.
① Click the Thicken in the Toolbar or choose Tools > Mesh Tools > Thicken in the menu.
② Check the Surface option in the Method.
Note. Thicken command provides two different methods.
The Surface method is one of the methods which expands or reduces the poly-faces in the mesh and
creates new offset poly-faces which are at specific distance away from the original mesh.
The Volume method is other method which constructs voxel structure that consists of 3D lattices with
uniform length from the mesh and creates new offset poly-faces which are away from the poly-vertices
by the size of the voxel.
③ Set the Thickness to 3mm and then check the Direction2, as shown in the image below.
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Note. The offset direction is based on the normal direction of the mesh.
The Direction1 is same as the normal direction of the mesh and the Direction2 is opposite to the normal
direction of the mesh.
You can also thicken the mesh in the both directions.
④ Click the Preview button.

⑤ Check the previewed result and then click the Accept button.

Mesh Shading

Point Shading

Note. Now, the mesh with predefined thickness is completely generated.
Tip. You can also check the thickness of mesh by using View Clip (View > View Clip).
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Step6: Optimize Mesh and Check Result
STEP1

STEP2

STEP3

STEP4

STEP5

STEP6

In this step, you can finally optimize the mesh and check the result.

Confirmed Accuracy

Optimized Mesh
1. Optimize Mesh
Finally, you can optimize the mesh.

① Click the Optimize Mesh in the Toolbar or choose Tools > Mesh Tools > Optimize Mesh in the menu.
Note. Finally, you can highly improve the quality of the mesh by using the Optimize Mesh command. The
Optimize Mesh command re-triangulates the poly-faces in the mesh and improves the quality of the
mesh. The size of the poly-faces in the mesh will vary according to feature shapes on the mesh.
② Check the High Quality Mesh Conversion option in the Method.
③ Set the Min. Edge Length Multiplier to 0.5 and then set the Max. Edge Length Multiplier to 3, as shown in the
image below.
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Note. Poly-faces in the mesh will be automatically reconstructed according to feature shapes on the
mesh, using the defined Min. Edge Length to the Max. Edge Length.
④ Click the Preview button.

⑤ Check the previewed result and then click the Accept button.

2. Check Optimized Result
Finally, you can check the optimized result.
① Check the result with Accuracy Analyzer(TM).
Note. Finally, you can find the deviation between the optimized mesh and the original mesh with the
Accuracy Analyzer(TM).
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Note. You can also check the quality of the optimized mesh with the Accuracy Analyzer(TM).

Curvature (Mean)

Environment Mapping
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