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1. Introduction 
This tutorial is intended for users who need to become quickly familiar with RapidWorks.  
Before getting into the detailed instructions for using RapidWorks, this step-by-step tutorial aims at giving you a feel for what you 
can accomplish with the product.  
 
This tutorial will guide you on how to completely design a freeform part using powerful surface modeling methods. You will learn 
surface modeling methods that can use to create a freeform body from 3D scan data. 
 

  
Scan Data Designed Model 

 

Training time required : approx. 60 min. 
Level of Difficulty :  Intermediate 

 

2. Data Files 
Joystick.rwl– scan data of joystick model 
Download: http://nextwiki.s3.amazonaws.com/resources/application/octet-
stream/740c0f308758012f2e2b00254b9c869c-frhgiypicbswc.rwl 
 
The sample data for this tutorial is provided by INUS Technology. It is the property of INUS Technology and is used for 
informational purposes only. Other than to identify this software and publication, individuals or organizations purchasing the 
software are not entitled to use the sample data without INUS Technology’s prior written consent. 
 
 
 
 

3. Overview 

What will you learn in this course? 
• Separate features from mesh 
• Edit mesh 
• Create a base freeform body by using Auto Surfacing method. 
• Complete a freeform model by using Surface Modeling tools and Modeling Features 
• Analyze modeling result with Accuracy Analyzer 

 

http://nextwiki.s3.amazonaws.com/resources/application/octet-stream/740c0f308758012f2e2b00254b9c869c-frhgiypicbswc.rwl
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What will you learn to do in this course? 
• You can separate features from a scanned mesh and edit the mesh. 
• You can easily create a base freeform body by using Auto Surfacing Method. 
• You can extract design intent area from the mesh and easily add more features onto the base freeform body by using the 

information. 
• At the end of modeling process, you can easily check the deviation between the designed model and the mesh. 

 

What does this exercise cover? 
  
Step 1. Import Scan Data and Separate Features 
You can import a scanned mesh as a target modeling data into 
the application. 
And you can separate features from the scan data. 

 
 
Step 2. Segment Feature Regions and Align Scan 
Data to Design Coordinate System 
You can segment feature regions on the scan data and easily 
align the scan data to a design coordinate system by using the 
feature information. 
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Step 3. Edit Mesh 
You can edit the mesh for creating a freeform body on the mesh. 

 
 
Step 4. Create Base Freeform Body 
You can easily create a base freeform body on the mesh by 
using Auto Surfacing method. 

 

 
 
Step 5. Add More Features 
You can add more features onto the base freeform body.  
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Step 6. Check Modeling Result 
You can finally check the modeling result. 

  

 

4. Modeling Process 

Step1. Import Scan Data and Separate Features 

 
In this step, you will learn how to import a scanned mesh as a target modeling data into the application and you can separate 
features from the scan data.  
The separated features will be used for adding feature shapes onto a base freeform body after the freeform body is completely 
created. 
 

  
Original Scan Data Separated Meshes 

 

 
 

 

 
 

 

 
 

 

 
 

 

 
 

 

 

 
1. Import Scan Data 
Follow this step by using the Joystick.rwl file. 

① Click the File Open button in the Toolbar or choose File > Open in the menu.  

STEP6 STEP5 STEP4 STEP3 STEP2 STEP1 
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② Select the scanned mesh data file (Joystick.rwl) and click the Open button.  
Download: http://nextwiki.s3.amazonaws.com/resources/application/octet-
stream/740c0f308758012f2e2b00254b9c869c-frhgiypicbswc.rwl 
 

 
 

③ The selected scan data is imported into the application in the Model View. 
Note. This is a scanned mesh data for a joystick model. 

 
2. Separate Features 

The model has several features. You need to separate the features from the mesh to easily create a base freeform 
body. 

① Select the imported mesh in the Feature Tree or in the Model Tree and click the Mesh button in the Tool Palette to 
separate features in the Mesh mode.  

 
Tip. You can also enter the Mesh mode to edit the mesh by double clicking the imported mesh in the 
Feature Tree or in the Model Tree. 

 
② Make sure that the Selection Mode is set to Rectangle and Visible Only option is toggled off, as shown in the 

image below. 

 
 

Note. If the Visible Only option is toggled on, you can select visible areas only on the mesh. 
If you want to select invisible areas as well such as under-cut areas, you need to toggle this option off. 

 
③ Select the feature area by drawing a rectangle on the Model View, as shown in the image below. 

   
 

④ Select the other feature area by holding Shift key (for multiple selection), as shown in the image below. 

Visible Only option 

http://nextwiki.s3.amazonaws.com/resources/application/octet-stream/740c0f308758012f2e2b00254b9c869c-frhgiypicbswc.rwl


 

8 RAPIDWORKS 3.5 TUTORIAL 
 

  
 

Tip. You select more feature areas with ‘Shift’ key. 
 

⑤ Choose Edit > Copy in the menu to copy the selected areas.  
 

Tip. You can also easily copy the selected areas by clicking ‘Ctrl + C’ key. 
 

⑥ Check that the selected areas are copied and click the OK button.  

 
 

⑦  Click the Mesh button in the Tool Palette to exit the mode.  
 

Note. You can exit the mode by clicking the  (Confirm) button on the right-bottom side of Model 
View. If you click the cancel button, all operations which you did in the current mode will be discarded. 

 
⑧ Choose Edit > Paste in the menu to paste the copied areas in a new mesh.  
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Tip. You can also easily paste the selected areas in a new mesh by clicking ‘Ctrl + V’ key. 
 
Note. You can easily separate features from the mesh by coping and pasting feature areas. 
The registered new mesh will be used for adding feature shapes onto a base freeform body after the 
freeform body is completely created. 

 

Step2. Segment Feature Regions and Align Scan Data to Design Coordinate System 

 
You have imported a scanned mesh into the application and separated features from the scan data so far. 
In this step, you will learn how you can segment feature regions on the scan data for identifying geometric shapes and easily 
align the scan data to a design coordinate system by using the feature information. 
The segmented feature regions will be used for easily extracting design intents from the mesh. 
 

  
Separated Scan Data Aligned Scan Data 

 

 
 

 

 

 

 

 
 

 

 
 

 

 
 

 

 

1. Segment Feature Regions 

You can segment colored feature regions on the mesh. 

① Select the copied mesh in the Feature Tree or in the Model Tree and then click the Region Group button in the 
Tool Palette to enter the Region Group mode. 

STEP6 STEP5 STEP4 STEP3 STEP2 STEP1 
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Tip. If several meshes are registered in the Feature Tree, you need to define a target mesh to create 
new entities. After you define a target mesh, all the deactivated modes in the Tool Palette will be 
activated and then you can create new entities from the target mesh in the mode. 
 
Note. When you enter the Region Group mode, the Auto Segment command automatically opens. You 
can just segment feature regions on the mesh. 

 
② Set the Sensitivity to 60 and then adjust the options, as shown in the image below.  

 
 

③ Click the OK button. 

 
 

Note. The segmented regions have different feature information and they will help you aligning the scan 
data to a design coordinate system as well as easily extracting design intent from the scan data. 
The color information is just used for identifying feature regions. It will be automatically and randomly 
generated on the scan data. 
So, it may be changed whenever you apply Auto Segment command to the scan data. 

④ Click the Region Group button in the Tool Palette to exit the mode.  
 

2. Align Scan Data to Design Coordinate System 

The scan data is usually scanned in a coordinate system created by the 3D scanner. If you want to use a final 
modeling result in your manufacturing process, you need to align the model to a design coordinate system. 

 
Note. The application provides you several alignment methods to easily align the scan data to a design 
coordinate system. 
One of alignment methods is Align Wizard. The Align Wizard automatically and intelligently identifies 
available coordinate systems by using the feature information from the scan data and recommends an 
appropriate coordinate system for the model. 
If you know how you want to align the scan data to a design coordinate system, you can use another 
alignment method which is called Interactive Alignment. The Interactive Alignment allows you to 
manually and interactively define a coordinate system by using the feature information or pre-defined 
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Ref.Geometries. 
In this case, the Interactive Alignment method will be used. 

 
① Make the copied mesh only visible in the Model View.  
② Click the Interactive Alignment button in the Toolbar or choose Tools > Align > Interactive Alignment in the 

menu.  
③ Select all the meshes as the target Moving Entities and then click the Next Stage button to continue.  

 
Tip. You can select all the registered mesh by selecting Meshes root entity, as shown in the image 
below. 

  
 

④ Check the X-Y-Z Moving option. 
 

Note. The application provides two different methods such as 3-2-1 and X-Y-Z to define a scan 
coordinate system. 
The 3-2-1 method allows you to define a coordinate system by using Plane, Vector, and Position. 
And the X-Y-Z method allows you to manually define an origin point and each axis of coordinate system. 
The X-Y-Z method will be used for this case. 

 
⑤ Select the planar feature region and the cylindrical feature region to define the origin position of a scan coordinate, 

as shown in the image below. 

  
 

Tip. If the target feature region is not identified as a plane, increase the Geometry Type Checking 
Tolerance so that the geometry type of the region can be correctly identified as a plane. 
Choose File > Preference in the menu and then increase the Geometry Type Checking Tolerance to 
‘0.2mm’ in the Tolerance tab, as shown in the image below.  
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Note. As you can see, the origin position and the X, Y, Z moving directions of a scan coordinate system 
are fixed. 

 
⑥ Click the Axis Z button to define the Z-axis of a scan coordinate system and then select the planar feature region, 

as shown in the image below.  

  
 

Note. As you can see, the X, Y rotations of a scan coordinate system are fixed by the Z-axis. 
 

⑦ Click the Axis X button to define the X-axis of a scan coordinate system and then select the cylindrical feature 
region, as shown in the image below.  

   
 

Note. As you can see, all the directions and the rotations of a scan coordinate system are fixed. 
 

⑧ Check the previewed result in the Transform Entity View and click the Flip button in the Axis X option and the 
Axis Z option. 

 
Note. The Flip allows you to reverse the direction of the axis in a scan coordinate system. 
When you click the Flip button, you can directly check how the scan data will be aligned to a design 
coordinate system in the Transform Entity View. 
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⑨ Check that the design coordinate system is set to Origin in the Target and click the OK button.  

 
 

Z-Axis 

X-Axis Y-Axis 

Origin 
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Step3. Edit Mesh 

 
You have segmented feature regions on the mesh for identifying geometric shapes and aligned the scan data to a design 
coordinate system by using the feature information so far. 
In this step, you will learn how you can edit the mesh for creating a base freeform body on the mesh. 
You need to optimize the mesh to create a high quality freeform body on the mesh. 
 

  
Original Scan Data Optimized Scan Data 

 

 
 

 

 
 

 

 

 

 

 
 

 

 
 

 

 

1. Remove Features 

Now, you can edit the mesh. In the first step of editing process, you can remove features from the original mesh. 

 
Note. Features are still present on the original mesh because the features have been just separated 
from the original mesh in a new mesh at in the previous step. 
So, you need to remove the features from the original mesh to create a high quality freeform body which 
can cover the entire model. 

 
① Make the original mesh only visible in the Model View. 
② Select the original mesh in the Feature Tree or in the Model Tree and click the Mesh button in the Tool Palette to 

edit the mesh.  
 
• Remove features 

① Check that the Visible Only option in the Select Option is toggled off and the Selection Mode is set to 
Rectangle. 

② Select the feature area by drawing a rectangle on the Model View to remove the feature from the original mesh, 
as shown in the image below. 

STEP6 STEP5 STEP4 STEP3 STEP2 STEP1 
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③ Choose Edit > Delete in the menu to delete the selected feature area from the mesh. 

 
Tip. You can also easily delete the selected feature area by clicking ‘Delete’ key. 

 

   
④ Change the Selection Mode to Polyline and select the other feature area by drawing a polyline on the Model 

View to remove the feature from the original mesh, as shown in the image below. 

  
 

Tip. The Polyline Selection Mode allows you to easily select feature area on the mesh by drawing a 
polyline on the Model View. If you click the right mouse button or double click the left mouse button at the 
end point of the polyline, you can completely draw a polyline. 
The inside area of the polyline will be selected. 
 
Note. If you select poly-faces with Visible Only option toggled off, some unwanted areas may be 
selected. 
If some unwanted areas are selected, you can deselect the areas by using ‘Ctrl’ Key 

 
⑤ Deselect the unwanted areas from the selected areas with Ctrl key, as shown in the image below. 
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⑥ Choose Edit > Delete in the menu to delete the selected feature area. 

 
 
• Edit features 

① Click the Edit Boundaries button in the Toolbar or choose Tools > Mesh Tools > Edit Boundaries in the menu.  
 

Note. Edit Boundaries provides several methods to edit boundaries. 
You can create a new mesh area by using the Extrude method which is one of the editing methods. 

 
② Check Extrude method and then select the boundary, as shown in the image below. 

   
 

③ Set the Method to Blind in the Extrude Options and set the Distance to -25mm. 
④ Check the Cap option and click the Preview button.  
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⑤ Check the previewed result and then click the Accept button.  
⑥ Click the Defeature button in the Toolbar or choose Tools > Mesh Tools > Defeature in the menu.  

 
Note. The Defeature helps you to easily remove features from the mesh and fill the holes as well. 

 
⑦ Change the Selection Mode to Circle and select the feature area by drawing a circle on the Model View, as 

shown in the image below. 

  
 

⑧ Deselect the unwanted areas from the selected areas with Ctrl key, same as in the previous step, as shown in 
the image below. 

  
 

⑨ Adjust the options, as shown in the image below and click the OK button.  



 

18 RAPIDWORKS 3.5 TUTORIAL 
 

  
 

⑩ Remove features on the other areas by using the Defeature command, same as in the previous step. 

  
 

2. Remove Features 

In the second step of editing process, you can fill the holes and create a closed volume mesh. 

① Click Fill Holes button in the Toolbar or choose Tools > Mesh Tools > Fill Holes in the menu.  
 

Note. You need to fill the holes to create a high quality freeform body on the mesh. 
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② Check if the Method is set to Curvature and click the Add Bridge button to create a bridge between the poly-
edges in the hole.  

 
Note. If a hole is big or complex to fill, the bridge helps you to divide the big hole into several small holes 
and easily fill the holes. 

 
③ Select the poly-edge in the left side of the boundary and drag the bridge to the other poly-edge in the right side of 

the boundary, as shown in the image below. 

  
 

④ Add a bridge between the other poly-edges, same as in the previous step. 

 
 

⑤ Click the Boundaries button and then select the divided boundaries, as shown in the image below.  

 
 

⑥ Click the Preview button and check the result.  
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⑦ Click the Accept button.  
 

3. Optimize Mesh 

Finally, you can optimize the mesh. 

① Click the Global Remesh button in the Toolbar or choose Tools > Mesh Tools > Global Remesh Mesh in the 
menu.  

 
Note. Finally, you can highly improve quality of the mesh by using the Global Remesh command. 
The Global Mesh command re-triangulates the evenly distributed poly-faces in the entire region of mesh 
and improves quality of the mesh. 

 
② Check the Make Clean And Manifold Solid Mesh option and then click the Preview button.  

  
 

Note. Make Clean And Manifold Solid Mesh option makes a clean mesh which has no any defects. 
Even though you have small holes in the mesh, the holes will be automatically filled. 

 
③ Check the previewed result by clicking the Preview button.  
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④ Click the Accept button.  
⑤ Click the Enhance Shape button in the Toolbar or choose Tools > Mesh Tools > Enhance Shape in the menu.  

 
Note. Enhance Shape command allows you to enhance typical feature shapes in the mesh. 
The low curvature areas will be much smoother and high curvature areas will be much sharper in the 
mesh. 

 
⑥ Set the Sharpness to the middle and the Overall Smoothness to Max, as shown in the image below. 

   
 

Note. You can adjust the weight of the sharpness and the overall smoothness by controlling the slide bar 
and you can also set the iteration of those enhancements by controlling the Enhance Level. 

 
⑦ Click the Next Stage button to continue. 

 
Note. You can adjust the iteration of enhancements in the second stage of the Enhance Shape 
command while you are previewing the result. 

 
⑧ Check the previewed result and then click the OK button.  



 

22 RAPIDWORKS 3.5 TUTORIAL 
 

 
⑨ Click the Smart Brush button in the Toolbar or choose Tools > Mesh Tools > Smart Brush in the menu.  

 
Note. Smart Brush provides several different methods to improve quality of the mesh. 
If you have rough areas in the mesh, the Smooth method allows you to manually reduce roughness in 
the mesh. 
You can also adjust the weight of the smoothness by controlling the Strength option. 

 
⑩ Check that the Method is set to Smooth. 
⑪ Set the Strength to Max and then apply the smoothness to the rough areas in the mesh by using the Paint Brush 

Selection Tool, as shown in the image below. 

   
 

Tip. You can adjust the range of the Paint Brush with ‘Alt’ key. 
 

⑫ Apply the smoothness to the other rough areas in the mesh by using the Paint Brush Selection Tool, as shown in 
the image below. 
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⑬ Check the result and then click the OK button. 
⑭ Click the Mesh button in the Tool Palette to exit the mode. 

 

Step4. Create Base Freeform Body 

 
You have optimized the mesh by using several mesh editing tools so far. 
In this step, you will learn how you can easily create a base freeform body on the mesh by using Auto Surfacing method. 
 

  
Optimized Scan Data Freeform Base Solid Body  

Created by Auto Surfacing Method  
 

 
 

 

 
 

 

 
 

 

 

 

 

 
 

 

 

1. Create Base Freeform Body 

Now, you can create a base freeform body by using the Auto Surfacing method. 

• Apply Auto Surfacing to the mesh 

STEP6 STEP5 STEP4 STEP3 STEP2 STEP1 
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① Click the Auto Surfacing button in the Toolbar or choose Insert > Surface > Auto Surfacing in the menu.  
 

Note. If you have a mesh which is a complex freeform shape, you can easily create a freeform body on 
the mesh by using the Auto Surfacing command. 
Auto Surfacing provides two different methods. One of methods is Feature Following Network. And the 
other one is using Evenly Distributed Network. 
Feature Following Network automatically recognizes feature shapes and it allows you to create a 
freeform body by following the feature shapes. 
And Evenly Distributed Network allows you to create a freeform body by using evenly distributed curve 
network. 

 
② Check the Feature Following Network method and select the optimized mesh as the target Mesh. 
③ Adjust options, as shown in the image below. 

   
 

Note. The Feature Detection Level detects high curvature areas in the mesh. If you increase the Feature 
Detection Level to ‘More’, more high curvature areas will be detected and a curve network will be 
automatically constructed on the mesh following the detected curvature areas. 

 
④ Click the Next Stage button to continue.  
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Note. As you can see in the previewed result, a curve network is automatically generated on the mesh. 
Now, you can manually modify the curve network in the second stage of the Auto Surfacing command by 
using several editing tools. 

 

• Modify curve network by using the Deform tool 
 

Note. The Auto Surfacing provides several different editing tools. 
The Deform tool which is the one of editing tools allows you to manually deform curves. 
You can deform a curve by dragging the curve and you can also deform curves by dragging the 
intersection point of the curves. 
When you deform a curve (or curves) by using the Deform tool, the deformation is performed by user-
defined deformation range. 
Click the ‘Alt’ key and then drag your mouse cursor on the Model View to change the deformation range. 

 
① Check the Deform tool. 

 
Note. You can also use the edit tools by pressing shortcut keys. 

 
② Modify a curve (or curves) by dragging the curve (or the intersection point of curves), as shown in the image 

below. 

  
 

Tip. If you deform curves by dragging the intersection point of the curves with the Apply Stiffening 
Around Crossing Vertices option checked, the curves will be deformed maintaining G1(Tangent) 
continuity in the intersection point of curves where the curves intersect into a T-junction or X-junction. 

  
    < T-Junction >                                             < X-Junction > 

 
③ Modify the other curves, same as in the previous step. 

 
• Modify curve network by using the Detach And Move tool 

 
Note. The Auto Surfacing provides several different editing tools. 
The Slide tool which is the one of editing tools allows you to manually move curves. 
You can detach a curve by selecting the target curve and you can also move the curve by selecting a 
point on the other curve where you want to move and attach the curve. 
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When you check the tool and select a curve, the curve will be highlighted by yellow color and the other 
curve where you can move the target curve will be highlight by green color. And then you can detach the 
curve and move it onto the other highlighted curve. 

 
① Check the Slide tool. 
② Select a curve and select a point on the other curve to move the curve, as shown in the image below. 

   
 

③ Check the moved curve and modify the other curves, same as in the previous step. 
 

• Modify curve network by using the Split tool 
 

Note. The Auto Surfacing provides several different editing tools. 
The Split tool which is the one of editing tools allows you to manually split curve loop. 
You can split a curve loop by selecting points on the curves. 
When you check the method and select a point on the curve, the other curves where you can set an end 
point of splitting curve will be highlighted by green color. And then you can set the end point of the 
splitting curve on the highlighted curve and the curve loop will be split by the curve. 

 
① Check the Split tool. 
② Select a point on the curve and select a point on the other highlighted curve to split curve loop, as shown in the 

image below. 

  
 

③ Check the created curve and split the other curve loop, same as in the previous step. 
 
• Construct curve network 
 

Note. You can finally construct a curve network by using the editing tools. 
You can use the other editing tools such as Remove, Merge, And Define Sharp Edges after you 
construct a curve network to easily modify the curve network. 

① Construct a curve network by using the editing tools, as shown in the image below. 
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Tip. If you deform the curves by dragging an intersection point of the curves with the Apply Stiffening 
Around Crossing Vertices option, after splitting curve loop by using the Split tool, you can easily 
construct smooth curves on the mesh. 

 
② Check the constructed curve network and adjust the options, as shown in the image below. 

 
③ Click the Preview button.  
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④ Check the previewed result and then click the Accept button.  
 

Note. Surface patches will be fit to the mesh by using the constructed curve network, and a freeform 
body will be automatically created. 
It will be used as a base freeform body. 

 
2. Check Result 

Finally, you can check the created freeform body by using the Accuracy Analyzer(TM). 

① Check the deviation between the created base freeform body and the mesh by selecting the Deviation button in 
the Accuracy Analyzer(TM).  

 
Note. You can check not only a deviation between the designed body and the scan data, but also 
continuity and quality of the designed body by using the Accuracy Analyzer(TM). 
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G1(Tangent) Continuity Environment Mapping 

 

 

Step5: Add More Features 

 
You have created a base freeform body on the mesh by using Auto Surfacing method so far. 
In this step, you will learn how you can add more features onto the base freeform body.  
Finally, the joystick model will be completely designed. 
 

  
Created Base Solid Body Solid Body Added Features 

 

 
 

 

 
 

 

 
 

 

 
 

 

 

 

 

 

 
 

1. Create Feature Shape (1) 

 

 

STEP6 STEP5 STEP4 STEP3 STEP2 STEP1 



 

30 RAPIDWORKS 3.5 TUTORIAL 
 

The model has several feature shapes, as shown in the image below. 

 

Now, you can add the feature shape (1) onto the base freeform body. 

• Set a sketch base plane and create a Section Polyline 
① Make the Copied Mesh only visible in the Model View. 
② Click the Ref.Vector button in the Toolbar or choose Insert > Ref.Geometry > Vector in the menu.  
③ Select Ref.Planes (Top Ref.Plane and Right Ref.Plane) as the target Entities, as shown in the image below. 

  
 

④ Check that the Method is set to Intersect 2 Planes and then click the OK button.  
 

Note. The extracted Ref.Vector will be used as a rotation axis for creating the feature shape (1). 

 
⑤ Select the Copied Mesh in the Feature Tree or in the Model Tree and then click the Mesh Sketch button in the 

Tool Palette to enter the Mesh Sketch mode. 
 
⑥ Change the Method to Rotational Method and then select the extracted Ref.Vector (Vector1) as the target 

Central Axis. 
⑦ Select Ref.Plane (Right Ref.Plane) as the target Base Plane. 
⑧ Check that the Section Polyline is correctly projected onto the base plane, as shown in the image below. 

Feature Shape (3) 

Feature Shape (1) 

Feature Shape (4) 

Feature Shape (2) 
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⑨ Click the OK button.  

 
 

Note. You are sent automatically to the Mesh Sketch mode and now you are ready to design a sketch 
profile. The selected Ref.Plane will be automatically hidden for better sketch view. If you want to see the 
Ref.Planes, toggle the Eye icon of Ref.Planes entity on in the Model Tree. 

 
• Design a sketch profile on the Section Polyline 
① Hide the meshes in the Model Tree. 

 
Tip. You can adjust resolution of the section polylines by moving the slide bar in the Segment Section 
Polyline Tool Palette. 
When you move the slide bar, the application automatically determines linear segments and arc 
segments in the Section Polyline and then you can easily fit sketches on the determined Section 
Polyline.  
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• Draw sketches 
① Click the Line button in the Toolbar or choose Tools > Sketch Entities > Line in the menu.  
② Check that the Fit Polyline option is enabled and then select the linear segment of the Section Polyline to create 

a line sketch on the Section Polyline, as shown in the image below. 

   
③ Click the Accept Fitting button to register the previewed sketch.  

 
Tip. You can easily register the previewed sketch by clicking the Accept Fitting button or double-click the 
left mouse button on the Model View without leaving the command. 
If you click the OK button, you will leave the command. 

 
④ Extract line sketches by selecting the other linear segments of the Section Polyline, same as in the previous step, 

as shown in the image below.  

 
 
 
 
 
 
 
 
 
 

Determined Linear Area of Section Polyline 

Determined Arc Area of Section Polyline 
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⑤ Draw a line sketch on the Model View from the V axis to the outside of the Section Polyline, as shown in the 
image below. 

  
 

⑥ Click the OK button. 
 

• Set constraints 
 

Note. The line sketches are generated by fitting operation. 
So, the line sketches may have a different orientation with respect to the design coordinate system. 
If you set constraints (Vertical or Horizontal constraint) to the sketches, you can fit it to a design 
coordinates (U, V Design Axis).  

 
 

① Double-click the line sketch, as shown in the image below. 

  
 
Note. Check that the Sketches root entity is visible in the Model Tree. 
If the Sketches root entity is currently invisible, you may not be able to select the designed sketch 
entities in the Sketch mode or in the Mesh Sketch mode. 

 
② Click the Vertical button in the Constraint section to fit the line sketch to V Design Axis.  

 
③ Check that the line sketch is set with a vertical constraint. 

 
 
 

V Design Axis 

U Design Axis 
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④ Select the other line sketch, as shown in the image below. 

  
⑤ Click the Horizontal button in the Constraint section to fit the line sketch to U Design Axis. 
⑥ Check that the line sketch is set with a horizontal constraint and then click the OK button. 

  
 

Tip. If you click right mouse button on a sketch, you can also easily set a constraint to the sketch in the 
pop-up menu. 

Vertical Constraint 

Horizontal Constraint 
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⑦ Set the Max. Dist. to 5mm and Intersection to 2.5mm in the Coincident section of the Disjoined Points 
Constraint Tool Palette and then click the OK button.  

 
 
 

Note. If you have disjoined points in the sketches, the Disjoined Points Constraint Tool Palette allows 
you to easily and automatically set constraints to the sketches. 

 
• Edit sketches 
① Click the Resize button in the Toolbar or choose Tools > Sketch Tools > Resize in the menu.  

 
Note. Now, you need a sketch profile which can completely cut the base freeform body. 
The Resize command allows you to easily extend the line sketch. 

 
② Select the end point of the line sketch and then increase the length of the line sketch by dragging the point to the 

outside of the Section Polyline, as shown in the image below. 
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③ Drag the line sketch onto the Section Polyline, as shown in the image below. 

  
④ Click the OK button. 

 
Tip. You can easily set the position of sketches onto the Section Polyline by using the Snap On Polylines 
option. 
The Snap On Polylines option can be toggled On or Off in the Toolbar. 

 
 
Note. The designed sketch profile will be used for creating the feature shape (1). 

⑤ Click the Mesh Sketch Button in the Tool Palette to exit the mode.  
 

• Create the feature shape (1) and add it onto the base freeform body 
① Click the Surface Revolve button in the Toolbar or choose Insert > Surface > Revolve in the menu.  
② Select the sketch profile (Sketch1 (Mesh)) as the target Base Sketch and then click the Axis button to define a 

rotation axis, as shown in the image below. 

  
 

③ Check the previewed result and then click the OK button.  
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Note. The feature shape (1) is created. 
Now, you can cut the base freeform body by using the feature shape (1) and completely form the feature 
shape. 

 
④ Make the base freeform body (Auto Surfacing1) visible in the Model View. 
⑤ Click the Cut button in the Toolbar or choose Insert > Solid > Cut in the menu.  
⑥ Select the created surface body (Surface Revolve1) as the target Tool Entities and then click the Target Bodies 

button to define a target body, as shown in the image below. 

  
 

⑦ Click the Next Stage button to continue.  
⑧ Select the remaining body, as shown in the image below. 

 
 

⑨ Check the previewed result and then click the OK button.  

Target Body 

Tool Entity 
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Note. The feature shape (1) is completely formed at the bottom of the freeform body. 
 

2. Create Feature Shape (2) 

The model has several feature shapes, as shown in the image below. 

 

Now, you can add the feature shape (2) onto the base freeform body. 

• Set a sketch base plane and create a Section Polyline 
① Make the Copied Mesh only visible in the Model View. 
② Select the Copied Mesh in the Feature Tree or in the Model Tree and then click the Mesh Sketch button in the 

Tool Palette to enter the Mesh Sketch mode. 
③ Check that the Method is set to Planar Method and then select the Ref.Plane (Front Ref.Plane) as the target 

Base Plane. 
④ Increase the Offset Distance From Base Plane to 83mm and then check that the Section Polyline is correctly 

projected onto the base plane, as shown in the image below. 

Feature Shape (3) 

Feature Shape (1) 

Feature Shape (4) 

Feature Shape (2) 
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⑤ Click the OK button.  

 
 

• Design a sketch profile on the Section Polyline 
① Hide the Mesh in the Model Tree. 
② Click the Parallelogram button in the Toolbar or choose Tools > Sketch Entities > Parallelogram in the menu.  

 
Note. The Parallelogram allows you to easily and quickly create a parallelogram which consists of 4 
parallel line sketches. 
You need 3 point to define a parallelogram. 

 
③ Select a first point and second point on the Section Polyline, as shown in the image below. 

  
 

④ Finally select a point on the outside of the Section Polyline, as shown in the image below. 
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⑤ Click the OK button.    
⑥ Drag the line sketch onto the Section Polyline, as shown in the image below. 

  
 

⑦ Drag another line sketch onto the Section Polyline, as shown in the image below. 

  
 

⑧ Drag the other line sketch to the outside of the Section Polyline, as shown in the image below. 

   
 

Tip. You need to prepare a sketch profile which has an enough width so that it can create a feature 
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shape and the feature shape can cut the feature off from the base freeform body. 

 
 
Note. The designed sketch profile will be used for creating the feature shape (2) 

 
⑨ Click the Mesh Sketch Button in the Tool Palette to exit the mode.  

 

• Create the feature shape (2) and add it onto the base freeform body 
① Make Visible the Copied Mesh in the Model View. 
② Click the Extrude button in the Toolbar or choose Insert > Solid > Extrude in the menu.  
③ Select the sketch profile (Sketch2 (Mesh)) as the target Base Sketch and change the Method to Up To Region. 
④ Set the Sub Method to Min.Distance Position. 
⑤ Select the planar feature region as the target Up To region, as shown in the image below. 

  
 

⑥ Check the Cut option in the Result Operator. 
⑦ Click the OK button.  
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Note. The feature shape (2) is completely formed in the base freeform body. 
 

1. Add Fillet 

 You can add a fillet to the created freeform body. 

① Make the designed body (Extrude1 (Cut)) only visible in the Model Tree. 
② Click the Fillet button in the Toolbar or choose Insert > Modeling Feature > Fillet in the menu.  
③ Set the Radius to 1mm and then check the Tangent Propagation option. 

 
Tip. The Tangent Propagation option helps you to easily find adjacency tangent edges. 
But, if the application cannot detect the edges, you need to manually select the edges to add a fillet. 

 
④ Select the sharp edges on the freeform body as the target Entities, as shown in the image below. 

  
 

⑤ Check the previewed result and then click the OK button.  
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3. Make Shell 

 Now, you need to make a shell from the base freeform body to add the other feature shapes. 

① Click the Hollow button in the Toolbar or choose Insert > Solid > Hollow in the menu.  
② Select the base freeform body (Fillet1 (Constant)) as the target Body and then select the bottom face of the solid 

body as the target Remove Faces, as shown in the image below. 

 
 

③ Set the Depth to 1mm and then click the Preview button.  

 
 

④ Check the previewed result and then click the OK button.  

Remove Face 
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4. Create Feature Shape (3) 

The model has several feature shapes, as shown in the image below. 

 

Now, you can add the feature shape (3) onto the base freeform body. 

• Extract feature shape from the mesh by using the Modeling Wizard 
① Make the Copied Mesh only visible in the Model View. 
② Click the Surface Primitives button in the Toolbar or choose Insert > Modeling Wizard > Surface Primitive in 

the menu.  
 

Note. The Surface Primitives allows you to easily extract primitive shapes from the mesh. 
So, you can create feature shapes by using the Surface Primitives and quickly add more feature shapes 
into the base freeform body. 

 
③ Check the Automatically Extract Shapes method and then set the feature shape to Cylinder in the Shapes To 

Be Extracted option list. 
  

Note. The Surface Primitives provides two different extracting methods. 
One of the extracting methods is Automatically Extract Shapes method. 
It can extract several different primitive feature shapes from the mesh by using the feature information 
according to your definition at the same time. 
If the geometry types of feature regions on the mesh have been identified as you want to extract, the 
Automatically Extract Shapes method will automatically extract feature shapes as they are. 
But, if not, use the other method. The Extract Specific Shape method will extract a feature shape as you 

Feature Shape (3) 

Feature Shape (1) 

Feature Shape (4) 

Feature Shape (2) 



 

45 RAPIDWORKS 3.5 TUTORIAL 
 

want to extract no matter how the geometry types of feature regions are. It can extract an average single 
primitive feature shape from the selected target feature regions. 

 
④ Set the Extend Ratio to 150%. 
⑤ Select the cylindrical feature region as the Target Regions, as shown in the image below. 

  
 

⑥ Click the Next Stage button to continue.  
⑦ Check the previewed result and then click the OK button. 

 
 

Note. The feature shape (3) is created. 
Now, you can cut the base freeform body by using the feature shape (3) and completely form the feature 
shape. 

 
• Add the feature shape (3) onto the base freeform body 
① Make the base freeform body (Hollow1) visible in the Model View. 
② Click the Cut button in the Toolbar or choose Insert > Solid > Cut in the menu.  
③ Select the created surface body (Surface Cylinder1) as the target Tool Entities and then click the Target Bodies 

button to define a target body. 
④ Select the freeform body (Hollow1) as the Target Bodies, as shown in the image below.  
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⑤ Click the Next Stage button to continue.  
⑥ Select the remaining body, as shown in the image below. 

 
 

⑦ Check the previewed result and then click the OK button.  

Target Body 

Tool Entity 
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Note. The feature shape (3) is completely formed in the base freeform body. 
 

5. Create Feature Shape (4) 

The model has several feature shapes, as shown in the image below. 

 

Now, you can add the feature shape (4) onto the base freeform body. 

• Set a sketch base plane and create a Section Polyline 
① Make the Copied Mesh only visible in the Model View. 
② Click the Ref.Plane button in the Toolbar or choose Insert > Ref.Geometry > Plane in the menu.  

 
Note. A geometric type of the bottom face in the target feature shape has been identified as Freeform. 
So, you need to extract a Ref.Plane from the mesh. The extracted Ref.Plane will be used as a base 
sketch plane for creating the feature shape (4). 

 
③ Select the freeform feature region as the target Entities, as shown in the image below. 

Feature Shape (3) 

Feature Shape (1) 

Feature Shape (4) 

Feature Shape (2) 
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④ Check that the Method is Extract and then click the Preview Button.  

  
 

⑤ Check the previewed result and then click the Accept button.  
 

Note. The extracted Ref.Plane will be used as a base sketch plane for creating the feature shape (4). 
 

⑥ Select the Copied Mesh in the Feature Tree or in the Model Tree and then click the Mesh Sketch button in the 
Tool Palette to enter the Mesh Sketch mode.  

⑦ Check that the Method is Planar Method and then select the extracted Ref.Plane (Plane2) as the target Base 
Plane. 

⑧ Set the Offset Distance From Base Plane to 0.2mm and then click the Flip Offset Direction button.  
⑨ Check that the Section Polyline is correctly projected onto the base plane, as shown in the image below. 

 
 

⑩ Click the OK button.  
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• Design a sketch profile on the Section Polyline 
① Hide the Mesh in the Model Tree. 
② Click the Slot button in the Toolbar or choose Tools > Sketch Entities > Slot in the menu.  
③ Check that the Fit Polyline option is enabled and then select the arc segments of the Section Polyline to create a 

slot sketch on the Section Polyline, as shown in the image below. 

  
 

Note. A best-fitted slot sketch is created from the selected arc segments on the Section Polyline. 
 

④ Click the OK button.  
⑤ Click the Mesh Sketch Button in the Tool Palette to exit the mode.  

 

• Create the feature shape (2) and add it onto the base freeform body 
① Make the base freeform body (Cut2) visible in the Model View. 
② Click the Extrude button in the Toolbar or choose Insert > Solid > Extrude in the menu.  
③ Select the sketch profile (Sketch4 (Mesh)) as the target Base Sketch and set the Length to 10mm. 
④ Check the Opposite Direction option and then set the Length to 10mm. 
⑤ Check the Cut option in the Result Operator, as shown in the image below. 
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⑥ Check the previewed result and then click the OK button.  

  
 

Note. All the feature shapes are completely formed in the base freeform body. 
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Step6: Check Modeling Result 

 
In this step, you can finally check a deviation and accuracy between the designed freeform body and the mesh. 
 

  
Completed Model Confirmed Accuracy 

 

 
 

 

 
 

 

 
 

 

 
 

 

 
 

 

 

 
1. Check Modeling Result 

Finally, you can check the modeling result. 

① Check the result with Accuracy Analyzer(TM). 
 

Note. Finally, you can check the modeling result with the Accuracy Analyzer(TM). 
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